Do I need the original device remote to program PUCK?

27/11/2017

Do I need the original device remote to program PUCK?

You do not need the original remote to use PUCK. Device compatibility can be verified at getpuck.com/search (please note the database is quite large and takes a minute to load).  If you do not find your device listed, please let us know by submitting your request at getpuck.com/request.

Copyright © 2020 SmashToast, Inc. All Rights Reserved.